Need to Know: the Vulnerabilities!

 Registration is closed for this event
A free webinar conversation about Meltdown and Spectre - two major computer vulnerabilities that were recently announced. What are they and how do we deal with them?

Technologists Jaime Villareal and Jamie McClelland will be presenting and leading the conversation at our upcoming webinar on The Two Vulnerabilities. Leadership Committee members Micky Metts and Alfredo Lopez will host and facilitate the event.

The program will start at 3:00 pm America/New_York time.

Simultaneous Spanish interpretation will be provided.

Micky Metts

January 25th, 2018 3:00 PM   through   4:30 PM

Help spread the word

Please help us and let your friends, colleagues and followers know about our page: Need to Know: the Vulnerabilities!


You can also share the below link in an email or on your website.
https://outreach.mayfirst.org/civicrm/event/info?id=21&reset=1